Page 1 of 1

Getting GRBL Flashed to Mega 2560

Posted: Sun Sep 18, 2022 9:18 am
by fitter11
I have been having issues getting GRBL to flash successfully to a Mega 2560 with the Mega Lite V1 board. I have not even gotten to the point that I've been able to test the board. I've tried both loading the hex file with X-Loader and the Arduino IDE and cannot get the sketch to load to the Mega 2560. Everything seems to go fine, the Rx and Tx lights flash and the sketch compiles and uploads without issues but GRBL doesn't work. when I use UGS, it shows being connected to the board but the controls are greyed out. i have tried everything that i can glean from these forums and the web in general and I'm at wits end. Can anyone help? I'm guessing it's something simple that I'm overlooking. Thanks in advance!!

Re: Getting GRBL Flashed to Mega 2560

Posted: Thu Sep 29, 2022 4:44 pm
by EccentricWorkshop
Have you tried using something other than UGS? I've not had much luck with it so I've used Candle or one of the other alternatives. Without knowing more, it sounds like a bad Arduino or bad connection to it.

If other software doesn't work, do you have another Arduino you can try?